Godot export to windows = black screen

Godot Version

4.2

Question

Beginner here.
I made a game. Exported it to windows.
Didn’t work. wouldn’t open, was missing a pck file.

Tried exporting it with embedded pkc.
Resulted in black screen.

Tried changing architecture from x86_64 to x86_32.
Black screen.

Tried with debug console. Gives following message:

Godot Engine v4.2.1.stable.officiale.b09f793f5 - https//godotengine.org
vkEnumerateInstanceVersion not available, assuming Vulkan 1.0.
Vulkan API 1.0.62 = Forward+ - Using Vulkan Device #0: Intel - Intel(R) UHD Graphics 620
WARNING: Invalid pipeline cache header.
at: _load_pipeline_cache (drivers/vulkan/rendering_device_vulkan.cpp:9200)

all other options are on default(how you receive it when you open export for the first time)

I don’t know what to do, please give direction.

have you tried opening the exported game on other windows devices?
or it’s completely missing .pck file after export giving no warnings/error on build?

ok, but if updating the driver doesn’t work, how do people make games with godot 4? then no one should be able to play them!
is there another solution??

I haven’t and I can’t, since I don’t own other windows devices but my laptop. That would mean I need to ask other people to test it…
I’ll try that out and will update if it does or doesn’t work.

Solution that worked:
Setting renderer in compatibility instead of forward+

Thank you for taking the time to read, answer and help me with solution!