GPUParticles2D appearing in editor, but not in game

Godot Version

4.2.2

Question

Hello, I’m having issues with the GPUParticles2D node. For some reason, the particles will not appear in game, even though they appear in the editor. I’ve worked with some particles in Godot before and never had this issue. I’ve used both particles that are always on (like smoke) and that only appear once (like when I shoot) and I’ve never had an issue with getting them to work. This particular particle effect is one shot, where emitting is enabled through code. The particles don’t appear even if I toggle emitting. I even made sure to copy some working particle effects and only adjust the colors, acceleration and other attributes in the Process Material, and only reduced lifetime to 0.2 seconds. Please let me know if there’s any other information I can help you with. I’m stumped.

The only time I’ve faced this with GpuParticles was when I had issues with the particles visibility rect.

Check and set the visibility rect of the particles.

For some reason, enabling Top Level fixed the issue, thanks for letting me know about the visibility settings.

1 Like