Help, I've changed texture filtering to "nearest" in the project settings, but my textures are still blurry!

Godot Version

4.2.1-mono

Question

I’ve set texture filtering in the project settings (Rendering-Textures) to “Nearest” but my 64x64 texture is still blurry in game. Tried reimporting the texture, but still nothing. Using Forward+ because I want to make a retro+ game (meaning blocky textures, but has modern conveniences of ambient occlusion, global illumination, etc.). Using BaseMaterial3D for the materials.

The default filter and repeat options in project settings is only for 2D. For 3D you need to setup the filtering and repeat modes in each material itself.

How do I do it for BaseMaterial3D?

In the StandardMaterial3D and ORMMaterial3D is under the Sampling group. In the ShaderMaterial you need to give a hint in the uniform Shading language — Godot Engine (stable) documentation in English

1 Like