Help with shadow casting in a 2.5D top-down game

Godot Version

4.2.1 stable


Hi, I’m trying to create a “2.5D” game using 3D nodes and a camera rotated to a 45° angle to recreate a sort of 2D top-down view. I’m also using GridMap as tiles for building the environment.
I’m trying to figure out what are the best settings for lights and shadows to have an environment that casts shadows in a way that the player can understand how high are the blocks and also to have the character to cast a shadow that, when jumping, the player understands where the character is going to land.
I got a good solution for the environment, but not for the player. I created 2 directional lights with different angles to achieve the result I wanted.
The problem is: I can’t exclude the character from casting a shadow from one of the 2 directional lights I have in the scene.
The character has a Sprite3D node with layer set to “2”

All the mesh instances have the layer set to “1”

In the main scene I have the directional lights set as follow:
Cull Mask layer 2 disabled

Cull mask all layers enabled

and that’s the result:

I just want to have one shadow for the character, the one casted by DirectionalLight3d_Top and disable the shadow casted by DirectionalLight3d_Angle but, even if I deselected layer 2 from the Cull Mask, the character’s shadow is still casting on the blocks.
The only way to get the result I want (but it’s not the solution, because it also changes the light of the blocks) is to deselect layer 1 from Cull Mask and that’s weird, because the character has nothing set to layer 1, but deselecting layer 1 that’s what I achieve:
[video is below because I can’t post more than one in a single post…]

but, as I said, this solution is not optimal because it makes the blocks darker and removes some shadows (because blocks are on layer 1).
Am I missing something? Maybe I’m not understanding how casting shadows works?
Please, help me find a solution :tired_face:

PS: sorry, I had to remove screenshots thet would have made everything more understandable because I’m new and I can’t post more than one attachment.

This is what I achieve deleselecting layer 1: