How to Make the Pixel Not Weird for Pixel Game?

Godot Version



How can I make the pixel not weird?

The viewport size is (512, 288).

The window size is (1280. 720)

This is if the window size is (1024, 576).

(I wanted to add two images in the beginning, but since new users can only post one at first, I have to add this one on the next post)

Have you tryd going into “ProjectSettings/General/Rendering/Textures” and changing the Default Texture Filter from “linear” to Nearest? (this usually helps when using pixel art).

In project settings where you set viewport size there are settings for stretching:
Mode: viewport
Scale Mode to integer for pixelart.
Not sure about Aspect. I’d say expand for this.

This should help making the pixels not look weird.

The texture filter is already “Nearest” from the beginning. So it’s not that.

My original settings:
Stretch Mode: canvas_items
Aspect: Keep

Anyway, changing scale mode to integer solve this.

I think it’s because when time it, there’s a comma.

For 1280x720, the viewport size (512x288) is timed with 2.5.

That .5 is the problem.

1 Like