How to solve Godot 4 crash on launch?

Godot Version

Godot 4.2.2


Godot craches when I try to open the project on Godot 4 ,
and leave the log below .
but it can be succesfully opened sometimes somehow .
LTS, 3.5.2 at this point works just fine on my laptop .
Im using 2021 omen 16 laptop with
AMD Ryzen 7 5800H with Radeon Graphics 3.20 GHz
Nvidia rtx3070 laptop gpu .
I,ve tried reinstall amd driver but nothing seems to change .
Someone please help me I really want to use this thing .

Source Godot Engine

Summary The application has stopped working.

Date 2024/05/02 11:01

Status Report has been sent.

Description Path of the application facing issues: C:\Users\senatang\Desktop\Godot_v4.3-dev6_mono_win64\Godot_v4.3-dev6_mono_win64\Godot_v4.3-dev6_mono_win64.exe

Problem Signature

  • Event Name: APPCRASH
  • Application Name: Godot_v4.3-dev6_mono_win64.exe
  • Application Version:
  • Application Timestamp: 00000000
  • Fault Module Name: amdxc64.dll
  • Fault Module Version: 31.0.21912.14
  • Fault Module Timestamp: 65cf0826
  • Exception Code: c0000005
  • Exception Offset: 00000000000a331f
  • OS Version: 10.0.22631.
  • Locale ID: 1041
  • Additional Information 1: 1df8
  • Additional Information 2: 1df83248a89c18c140bf3f74642531a4
  • Additional Information 3: 0aec
  • Additional Information 4: 0aeca1d843d69be614fc5d8d048ec2a1

Additional Information Bucket ID: 397e82ac8b49196e0e419a4897fcf6c4 (2180193331202291396)

Godot 4.2.2 got same problem on my laptop .

Can you try without the mono?

I have no idea what mono is and how .

In your crash log it says that you are using the mono compatable version of godot. This basically means C#. To get a copy without it go back and download the one that doesn’t say mono

Ok.I tried it ,but same issue .
Thanks for willing to help though .

can you check if you update all the drivers and the windows update

Yeah Ive done that already .Ive checked 100 times .

have you try to run as admin or run with the command to see more information

Yep. Nothing changed.

  • Fault Module Name: amdxc64.dll

I guess this is what I have to deal with .
Just don’t know what I can do.

run with the command shows nothing after

Editing project: C:/Users/senatang/Desktop/Godot projects/4.2.2
Godot Engine v4.2.2.stable.official.15073afe3 -

it just crash like nothing happend.

If you think that the problem try redownloading the dll file

I recomnend you open an issue on Godot github, there will be more easy to find help for that type of problem:

Issues · godotengine/godot (

It also says something about amd. Do you have an amd gpu? If thats the case you may have to update your drivers.

Take a look at this forum on amd: Link

Someone else was having similar problems running Eldin Ring (Which also uses Vulkan afaik) and they had a faulty memory module. Having the same issue on your laptop is the most confusing part, seeing as that build works for me on an AMD card i would guess its something with your setup(s)

I just saw this session right before I decided to ask for help.But I don’t understand what does he mean by

“All I did was install AMD drivers and then uninstalled the windows drivers that would keep changing it. I only had to do it once and I no longer have this problem.”

AMD driver understandable
Windows driver?