Imported model has black hashing near some vertices

Godot Version



I imported several models off of turbosquid. Most of them look great, but a couple have black hashing at certain vertices. What causes this? Any solution inside of Godot or to I need to have the source files and use Blender?

Can you take screenshots while using the wireframe debug draw mode (click the Perspective button in the top-left corner of the 3D viewport)? Also try the Unshaded and Overdraw debug draw modes.

Thanks for the reply. I just opened the project again and the black artifacts are gone. If the problem comes back I’ll post an update.

Bumping this thread as I got the same issue. I have recently downloaded Godot v4.2.1 to see what’s new and the first model I imported came with this black hashing issue. This seems to be present only on Forward+ Renderer (as I switched to Mobile and the issue was gone) and did not happen on versions 4.1 and earlier. I tried opening the project again and the artifacts are still there.
These artifacts also show on Wireframe and Unshaded. They slowly fade out as I switch to Overdraw but instantly return on any other view. They also do not show on Orthogonal view.
This issue only happens if I add any opaque material override.
Same behavior occurs on fresh created projects.

(Had to make a single image showing all views because I’m a new user)

Do you have TAA or FSR2 enabled in the project settings?

The fact this is only visible in Forward+ indicates one of two things:

  • The depth prepass is overly eager and is culling some pixels it shouldn’t
  • TAA/FSR2 makes it so the overdraw debug draw mode progressively fades in, as opposed to doing so instantly.

The Mobile rendering method doesn’t use a depth prepass and doesn’t support TAA or FSR2.

Either way, we need access to a minimal reproduction project to be able to troubleshoot this.

Sorry for the delay.
I did have FSR2 enabled, but that was not the root cause as it also happens on a fresh project. I disabled it and no changes. Disabling or enabling TAA also did not change the artifacts.

Where should I send the sample file? I prefer not to share this model with everyone.

Edit: More points I noticed that made the issue go away:

  • Setting Transparency to Depth pre-pass (Disabled as default)

  • Setting Cull Mode to Disabled (Back as default)

  • Enabling SSR, SSAO, SSIL or SDFGI

Thank you!

Can you try checking Force Disable Compression in the Import dock after selecting the 3D scene in the FileSystem dock? Also try toggling Ensure Tangents.

1 Like

Checking Force Disable Compression solved the issue!
Ensure Tangents made no difference.

Do you still want the project file?

If disabling mesh compression resolves the issue, it’s likely that the source mesh has invalid tangents somehow.

We probably can’t do anything about it – it’s an issue with the source file that needs to be fixed in the 3D DCC, but if you don’t have access to the model source, trying to fix it may prove difficult.