iOS builds crash when integrating project folder into XCode project

Godot Version

Godot Engine 4.2.stable.mono.official [46dc27791]


I’ve got the following issue:

iOS builds of my game work fine when being simply exported from Godot and build in XCode. No issues there!

However, in the documentation, there’s a promising and fairly simple guide (Active Development Considerations) about how to link a game’s project folder to the exported XCode project which then would allow for much faster deployments without needing to export a new XCode project from Godot for every little change.

Unfortunately, this does not work for me, despite the very simple and straight-forward steps. When building the project to a device, the build succeeds but always crashes immediately after the Godot splash screen. The error, unfortunately, is very cryptic: Thread 1: ESC_BAD_ACCESS (code=1, address=0x0) and the stack-trace not helpful, either (see screenshot). But I think it seems to be some sort of null-reference-exception because of the address=0x0 thing.

Now, since builds play just fine without the project folder integration into XCode, the problem must lie with the three very simple steps of 1. linking the project folder to the XCode project, 2. deleting the XCode projects .pck-file, 3. adding the “godot_path” property to the Info.plist file.
But I have repeated the whole process like 5 times, always with a fresh export and different folder names, without any success.

Given that the error seems to be a null-reference-exception, I kind of suspect something about the godot_path not working, but I’m not sure what to do/try about it.

Does anybody have an idea what could have gone wrong or what I could try? Does project folder integration into XCode work for anyone?

I’m on a M1 Mac Mini and the project’s written in C#, if that is of any relevance.

As a quick addition, here’s how my setup in XCode looks. I presume it’s exactly like the guide says, but maybe I’m overlooking something?

PS: Tried another, new Godot project. Same result! Perhaps I should file this as a bug?

Okay, this is indeed something that simply does not work when using C#/.NET. Here’s a related bug report: Linking .NET Godot project files into iOS XCode project breaks build · Issue #86019 · godotengine/godot · GitHub .
This really should be mentioned in the documentation.