Isometric Tiles Alignment Issue in Godot

Godot Version

Godot 4

Question

Hello everyone,

I am currently facing an issue with the alignment of isometric tiles in Godot and cannot seem to resolve it despite multiple attempts. Here are the details:

Current Configuration
TileMap Type: Isometric
Tile Size: 128x66 pixels
Current Settings:
Tile Shape: Isometric
Tile Layout: Stacked
Tile Offset Axis: Horizontal Offset
Y Sort Enabled: On
Y Sort Origin: 0
Problems Encountered
The tiles do not align correctly, creating visible gaps between them.
What I’ve Tried
Checked Tile Dimensions: The dimensions of the tiles in my TileSet file match those specified in the TileMap (128x66 pixels).
Enabled and Configured Y Sort Origin: I have enabled “Y Sort Enabled” and set the “Y Sort Origin” to zero. I have also tried adjusting this value slightly without success.
Adjusted Grid Settings: I have tried modifying the offsets of the isometric grid.
Verified Tile Alignment in TileSet: I checked the alignment of the tiles in the TileSet editor to ensure there were no small alignment errors.
Tested with Other Tile Sets: I tried using other tile sets to see if the problem persisted, and it seems to be the same.
Updated Godot: I am up-to-date with the latest stable version of Godot.
Checked Z-Index Values: All tiles have the same Z-Index to avoid sorting issues.
Screenshots and Files
You can see a screenshot of my issue below:

Resources and Help Consulted
I have consulted several forums and tutorials, including:
Godot Forum on Y Sort Issues
Tutorial on Y Sort in Godot
GitHub Discussion on TileMap Issues in Godot

Has anyone else encountered this problem and found a solution?
Are there specific steps or additional configurations I should try?
Any suggestions or advice would be greatly appreciated.
Thank you in advance for your help!

Do you have y-sort activated on the tilemap-layers?

3 Likes