Lightmap Baking makes scene dark

Godot Version

4.2

Question

Hi all, I am having a very annoying issue with Lightmap baking. The dynamic lights slow down the game tremendously so I am trying to bake them using the lightmapGI node. The problem is, when I bake the lights, the lights essentially “turn off”. Everything is pitch black and the only visible light is from the emissive materials.**

Here are the steps I’ve followed:

  • Unwrapped UV2 for all meshes
  • Set light bake mode to Static for all lights and meshes
  • Added world environment with sky
  • Added reflection probes for each room
  • Added lightmapGI node with environment set to scene
  • I also tried it with different settings such as enabling and disabling directional and interior and it does not change the result

Any help would be greatly appreciated!

EDIT:
I believe I have figured it out. I increased the size property in the inspector in each light and it seems to have worked. I am still getting some weird artifacts but the scene is at least lit.