Missing icon-tray icon on Steam version

Godot Version

Godot 4.2.1 Steam Linux

Question

Both on KDE and Cinnamon the icon-tray icon is the generic “missing icon” icon.
image
The Flatpak version does not have this issue.
image

Is there any technical reason for this?

The Flatpak provides its .desktop file and icon, while the Steam version is run directly by Steam. I’m not sure if we can do anything about it, as Steam expects it to be given executables rather than .desktop files when you set up a game/app on Steam.

Remember that on Linux (unlike Windows and macOS), apps can’t store their own icons that will be displayed when the app isn’t running. This is why a separate .desktop file is needed, along with one or more icons in PNG or SVG format. The Windows counterpart to .desktop files are shortcuts (.lnk).

1 Like

Running Godot via Steam from the application launcher gives it an icon. Peculiar.

It also seems that Godot gets an icon for the rest of the session if it’s been opened once like that.

I just wondered if it was a known bug.

Ah.
Apparently Steam sets the icon using the LinuxClientIcon setting. Godot has it set correctly. So it’s a Steam bug, not a Godot one.