Moving sprites having "antsy" edges

Godot Version



Hello, I noticed that when I move sprites edges of texture may or may not become “antsy” => edge pixels turn to “ants” that keep permanetly move in given edge space(swaping places with other pixels of texture around it), texture per se is still round and have same shape in general…

It happens only if sprite is moving, but the amount of antsy is determined by speed of sprite => at some speed, there is no issue at other speed smaller at other bigger…

I tried various ways to fix it, but none have worked as desired => snap to pixels may fix the issue, but movement becomes jittery then…

After searching for answers I found out that if movement speed is not matching your refresh rate it can cause issues… => which let to me find out that at certain speeds issue is not happening…

If I change speed/angle and keep it at certain values it can solve the issue, but I would prefer if I could have “360” angle and speed variation from x to y(float)…is there other way to fix this issue? Or I must pick between antsy edges or smaller speed/angle variations only?

did you try enabled the use mipmap for the sprites?

I did, didnt help…

Well if we speak of resource importer setting

tried all of these options and it still “antsy”?

1 Like

did you resized(to smaller than its original pixel) the texture first here before moving it around?

Just tried that and it gave various results with linear mipmap/linear mipmap anisotropic giving best results…tho I feels like movement is bit laggy(not so bad as with snap to pixels)…

btw I remember when I had the project in godot 3.5, changing repeat to disabled helped with similar issue too so I changed that too just in case(and I see the setting was “hiding” here, couldnt find it on importer xD)…

So if I use the linear mipmap antsy edges are fixed, but at the edges of texture where top, bottom, right and left of circle is “touching” edges they are “bubbly” I assume its because I should have created the texture with little more space at the edges and some sort of leaking is happening there or?

Texture is resized from bigger to smaller

usually when thing like repeated pixels near edges, you might want to have the image edges at least 1 pixel transparent

After leaving some space at edges of texture the bubbly issue is gone(the repeat is disabled btw)

So best result is when I pick:

linear mipmap/linear mipmap anisotropic
edges of texture have “transparent border”
repeat is disabled(tho it seems to have no effect)

btw there seems to be still bit of “antsy”, but is far smaller than before(I assume with pixel art or art changes it could be without it)

strangly enough if I blur the texture bit it becomes more ugly(there is some transparent white “shadow” and “CRT effect” on borders of texture

Okay, for the “CRT effect” and white shadow transparent it was my bad…forgot to generate mipmaps for resource in importer…welp

other way to fix it is, because you resized it to certain size, you will want to have the texture to be exact or near the resized size. or just make 2 different texture: big and small one

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.