My player character not showing up when i hit play

Godot Version



Recently 2 days ago started learning Godot. Running Godot 3.5.
Main scene is also selected. But when i press play nothing is visible on screen. I have a animatedSprite and it doesnt show up.

Help me on this.

Here is my project attached: - Google Drive

i havent download the project yet, but when you press play or F5 button, it should play the main scene
make sure your main scene is the correct one, or try F6 instead on that animatedsprite, see if anything is visible

see this image.

i pressed on animatedSprite then pressed F6. But still nothing is visible.

does your player animated sprite actually has a script that on _ready() function it play an animation?
or there’s no script

no script.

still a weird case, because usually even without script, if your sprite has an image, it should show on default show it:

I’m following a tutorial that uses Godot 4. And i’m applying it on Godot 3. So there is no there is no script added in godot 4, should i add one in godot 3? and what that wiil be in that script?

Can you run my project and confirm that it not a bug in my machine!

my pc now has no godot 3.5 engine installed, so i will need to download one to open that project in 3.5

if you try to move the player to the right and bottom, will you see the character

no, cause there is no script. Just the AnimatedSprite

Can you join a google meet?

there’s nothing here too

but now there is

1 Like

Yes. Can you help me to find any solution for this . :pray:

i just moved the instantiated player scene to the middle, not the camera middle

Camera2D in godot 4 and godot 3 works kinda differenty. in godot 4, once you make the camera as a child of the Player, it will focus on that player and make it in the middle, while Godot 3 doesnt

Thanks a lot. But how is the camera actually working? Shouldn’t i add my player in middle of the camera?

i no idea too for godot 3, as i mentioned just now, godot 3 camera2d doesnt make the parent of the camera2d as the center of the game, instead it just got ignored, probably will need to learn more about how to use the camera2d properly in godot 3

1 Like

i know how now
you just need to check the Current property to use the camera

in godot 4, it’s enabled by default, hence why it works on godot 4 just now but not godot 3
Godot 4 Camera2D:

1 Like