Pixel 2D Jittering

Godot Version

4.2.2 Stable

Question

Hello everyone!

I am experiencing Jittering but I don’t know why. My textures are 16x16 and the game window size is 320x180. The override size is 1280x720. I have attached a video above. I have no camera in the scene. Here’s what I have tried:

  • Snap 2D transforms to pixel turned on
  • Snap 2D vertices to pixel turned on
  • Stretch mode to viewport on
  • Stretch aspect to keep
  • Moving player in physics process
  • Moving player in process using delta
  • Canvas textures default texture filter set to nearest
  • Antialiasing disabled.
  • Anisotropic filtering to nearest and disabled.
  • Setting the player texture 2d filter to nearest.
  • Integer scaling instead of fractional
  • V-sync off
  • limit FPS to 60

I welcome any help. I don’t know what could be going wrong :frowning:

You might also want to set integer scaling? Seems like you’ve run through about every option, sorry!

Tried it as well but sadly it didn’t work.

Try this:

go to Project > Project Settings > Rendering > Quality > 2D > Use Pixel Snap and turn this On.

go to your 2D viewport, in the panel top bar next to the grid snap symbol, click on the three vertical dots, and the enable “Use Pixel Snap”

Thank you, but it’s already enabled.

Managed to kind of fix it.

I added a random camera to the scene and set the process callback on the camera to physics. It’s not perfect but the deformation has gone way down.

1 Like

Interesting, thank you for posting your solution! Must have needed a camera object to apply some of the effects. The jitter now is likely snaping to pixels, an inherit and wanted effect from pixel art games. Increasing resolution gives you more pixels to snap to :upside_down_face: