Question about excessive Frames per Second

Godot Version



I’m making a game prototype in Godot and ran into something weird concerning FPS. The number of frames per second is more than 5000 and the GPU is at 100%. In the Project Settings, FPS is at the default value of 0 and V-Sync is enabled. Actually, whichever V-Sync mode I choose, FPS remains at 5000+. The only way to reduce it is to set the FPS option to 60.

Is that expected? Is there a way to really use the V-Sync?

By the way, it’s fully reproductible with an empty project.

I wouldn’t assume so, but there are default rendering settings and game effects that could put an old GPU to work. I assume it doesn’t do so for 4.2? I guess the fps is slightly strange occurrence

I think there is an option to latch physics to rendering, I could be mistaken. I think you could bring up the issue in GitHub

Thanks. I have a modern gaming rig, so I don’t think it’s the issue.
I’ll try in 4.2.1 first.

There could be a bug in 4.2 too maybe, there is an issue related to frame synchronization. I wonder if this could be related?

There is a fix up, but not sure if its in your 4.3.dev1 release yet?

Update: no its still pending merge

I didn’t read it closely, but there could be specific frame_lag settings that somehow puts Godot in a weird positions with its frame synchronization? maybe starts to free-wheel out of control?

Thanks again. I will open an issue to be sure.

I opened this issue:

For reference, the answer is in Excessive frames per second due to V-Sync not being obeyed since 4.3.dev1 · Issue #87020 · godotengine/godot · GitHub

Double-check V-Sync isn’t forcibly disabled in NVIDIA Control Panel, including for any Godot application profiles in the Manage 3D Settings tab.

Actually yes, it is disabled here. I completely forgot about it. It was a hack to keep the editor from black flickering and stuttering. I removed the profile and the game is correctly synchronizing with the screen now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.