Scaling/Position is just wrong on some computers

Godot Version

4.1.2

Question

So, I’ve been making this game for a good while, and it’s been going great. I thought. Whenever I have someone else download my game, scaling and position are often incorrect.
I have been developing this game using both my expensive pc when at home, and my terrible laptop when on the go. It works perfectly on both.
When sending it to my friend, it looks like this:

If i remember correctly another friend of mine had the same issue but I thought we fixed it. The friend is using “Intel - Intel(R) UHD Graphics 600” according to the log files. The background is done using a parallax background node and the lantern pole is a CanvasLayer. I am building to windows.
I have tried changing the resolution and scaling settings in project settings, messing with the resolution of my monitor, all to no avail, and testing is extremely tedious since I can’t replicate the issue.
This is as much information as I can think of to give, so I’m really hoping for some help. If you need more information, please ask, this is annoying.

I can only send one embedded media per post, so I had to separate this.
This is what it is supposed to look like:

may i see the scene tree of how the parallax background and parallax layer with its sprite2d being put in runtime?
also the canvas layer of the lantern

You might run into Zero child of CanvasLayer (which is a child of Camera2D) may render with wrong transform [Windows, Intel HD 630 or lower] · Issue #58314 · godotengine/godot · GitHub with embedded graphic cards.

1 Like

Do you have a reccomended fix for it?

Since this is a driver-bug, this can’t be solved in Godot. As far as I understand the problem of the linked bugreport, it affects only the first child of a canvas layer, you might circumvent the problem, by inserting an additional dummy CanvasItem as first child.

Hey! late now, but figured out I can just change my rendering mode to compatibility.