SCons command fails because of errors whilst trying to set up GDExtension

Godot Version

4.2.2

Question

I am working on Windows 11
I recently downloaded the stable mono version of godot that can be used with .NET from the main website as a zip file. I extracted the zip folder to C:\Program Files so the path to the godot executable is C:\Program Files\Godot_v4.2.2-stable_mono_win64\Godot_v4.2.2-stable_mono_win64.exe
I then wanted to be able to use C++ in Godot so I followed the instructions here to try and set it up. I have all of the prerequisites needed (Godot 4 executable, C++ compiler - MinGW, SCons installed through pip, godot-cpp repository downloaded as zip file from 4.2 branch).
I ignored all thr instructions about the example and went to the Binding the C++ Bindings part.
godot isn’t a recognised command on my cmd so I used the full path of the godot console executable in place of the godot command (file called Godot_v4.2.2-stable_mono_win64_console.exe). This file is in the same directory as the normal godot executable file.
From the same folder as the godot-cpp-4.2 folder was stored, I ran the command "C:\Program Files\Godot_v4.2.2-stable_mono_win64\Godot_v4.2.2-stable_mono_win64_console.exe" --dump-extension-api and get the extension_api.json file appear.
I then run the command scons platform=windows custom_api_file=C:\Users\joelh\Downloads\godot-cpp-4.2\extension_api.json and get an error in the output.

I have put the full console output here if you want to see the console output (no space on the post). The above command is the last but one command, the below command is the last command in the file but the file includes the entire process I outlined here.

I then tried again with the argument bits=64 on the end like the instructions suggest so I ran scons platform=windows custom_api_file=C:\Users\joelh\Downloads\godot-cpp-4.2\extension_api.json bits=64 and got another erroneous output (the last command and output seen here).

I am not sure what went wrong, whether my prerequisites were wrong or whether something else is wrong. Please can someone help!

Blockquote
In file included from src\core\memory.cpp:31:0: include/godot_cpp/core/memory.hpp:109:53: error: ‘is_base_of_v’ is not a member of ‘std’

It seems like you don’t have C++ installed, or the library path isn’t setup correctly, or maybe the wrong standard of c++??

It seems like you don’t have C++ installed, or the library path isn’t setup correctly, or maybe the wrong standard of c++??

@pennyloafers Thanks for the reply, I’m quite new to this so could you suggest any way that I can check or fix this problem please?

${MINGW_PREFIX}/bin/x86_64-w64-mingw32-gcc --version

Does this command work above?

And did you use this option in your scons command? use_mingw=yes

These suggestions came from the docs