SubViewport not working on web browser

Godot Version 4.2

Hello everyone, I’m making a 3d web game and I found some issues with the subviewport. Somehow it shows me the viewport (a video) when I run the game in Godot, but when I run it on web it doesn’t show the video.
I’ll upload the two examples used in the game that give me the same issue.
Thank you if you’ll help me! :slight_smile:

This is the second item

Please note, that the SubViewportContainer displays an exclamation mark in the scene tree.

Such an exclamation mark usually means that something is not setup correctly. You can hover the mouse over the exclamation mark to get additional infos about the problem.

In this case the problem is, that the SubViewportContainer doesn’t contain any SubViewport, so it doesn’t display anything. If you want to display the SubViewport within the SubViewportContainer, then you should switch their positions in the scene tree.

Yes, I’m aware of this warning, but if I do that it just makes everything weird and still doesn’t work on web

This is running in Godot

This is running on web

The fact that Desktop and Web behave differently should be considered a bug.
Could you please open a bug report on Github Issues · godotengine/godot · GitHub and share a minimal reproduction project, that demonstrates this problem?

Yes sure, I’ll do it right now, thanks! :slight_smile:

1 Like