Subviewport texture is blurry but settings are set to nearest

Godot 4.2

Hello !

I’m trying to simulate a pixel art game on a 3D mesh but everything is blurry even though everywhere where it’s possible to set the texture to “Nearest”.

Do you have any idea how to achieve what I want ?

Try to set nearest to sub viewport or sprite2D

It already is sadly :confused:

You need to double-check several properties, as bilinear filtering may be enabled in either of them currently:

  • Make sure the Sprite2D node is rendered with nearest-neighbor filtering. Configure its texture filter mode in the inspector to Nearest, or set the default canvas texture filter mode in the SubViewport node to Nearest.
  • Make sure the BaseMaterial3D the MeshInstance3D is using has its texture filter mode set to Nearest.

Both need to be set to Nearest to achieve the desired effect.

1 Like

You were right, it was the sampling in the 3d model that was not set to Nearest !