Tileset: Can't select some tiles

Godot Version

v4.1.3.stable.official

Question

I created a tileset resource with a new atlas. I then tried to select all the tiles, but wasn’t able to select tiles in the very right column of the tileset and in the last row of the tileset. Below is a picture of the issue I am facing.


I already tried to increase the size of the sprite. When increasing the size of the sprite I can select all tiles, but unfortunatley some objects share one tile. So for example the street lantern shares one tile with the flower pot.

Looking at the white tiles next to the tree the fact that they dont line up with the grid leads me to think that theres an offset problem. Maybe try reimporting the tileset.

1 Like

Hi, thank you for your quick answer. I tried reimporting the tileset multiple times and it is still not working.

For example if im doing a tile set of four 32by 32 blocks i would make my canvas 32 by 128 and when the sprites are placed next to each other they perfectly create what is needed for the tileset. It appears some of your sprites are somewhat arbitrarily placed in the initial canvas so they dont fit the tileset grid.

1 Like

I didn’t create the sprites myself. I bought them from someone so I don’t know if they are placed incorrectly. I asked the same question on stackoverflow and got one answer. (See the picture of the question below). I was recommended to increase the size of my spritesheet. I did this and then I was able to select all the tiles. However, as can be seen in the image below, some objects share a tile when I enlarge the sprite sheet. This makes the tiles unusable.

What size did you increase it to? Is it a multiple of 16?

1 Like

yes I increased it in Photoshop to 1248 x 928.

Not sure about photoshop but when i increase canvas size in Asprite i have to specify in which direction i want the growth to occur. Its possible it added the extra size uniformly to the edges and now the actual spritesheet is floating in the middle of an off center grid

1 Like

Ohhh yes that could be the case. In photoshop I didn’t see any option to increase the size in a specific direction. I try to do it in Aesprite.

where is this option in Aesprite?
image

Try canvas size it should be just below sprite size

1 Like

Thank you so much! It works now! I really appreciate your help :smiley:

Happy it worked out for you

1 Like