Uploading to google play using godot shows Android App Bundle not signed yet?

Godot Version

4.2.1

Question

Hello everyone
Recently I tried to use godot to develop a small APP
Want to try uploading to google play
But I found that no matter how I upload it, it always displays
“The Android App Bundle has not been signed yet”

I have used release keystore and debug keystore

I generate the keystore instruction and execute it in the bin of jdk

keytool -genkey -v -keystore zoearth_godot_test_reless.jks -alias zoearth_godot_test -keyalg RSA -keysize 2048 -validity 10000

But it still keeps showing this error…
I remember that I didn’t encounter these problems when publishing with unity several years ago.
I searched online and couldn’t find a solution to this error.

make sure it’s in mobile rendering
not forward+

Thank you for your response.
I compile using Android ABB.
I’m not quite sure what you mean.
Could you please elaborate?
Thanks.

image
i mean this, if you set it to forward+, it wont be signed from what i experienced

Thank you for your reply. I’ll give it a try. Appreciate it.

1 Like

I encounter the same error.
I don’t know what to do.

202402021413

so it’s not the problem
what i found from searching, try their suggestion, one of them suggested to use jarsigner or keytool

Me too facing same issue. But in my case I am using Unreal Engine.