UV2 unwrap disabled my shadows

Godot Version

V4.2 stable


For context: I recently joined a company who were already working on this project and I’m very new to this engine.
All the meshes are imported as blender files, I’ve had to turn on ‘‘editable children’’ to be able to make the mesh unique and be able to unwrap, But unwrapping disables shadowcasting like the mesh isn’t even there. It’s for a mobile game so I’m not sure if realtime lighting is a good option.

Which rendering method are you using? Can you take screenshots of what it looks like before and after you enable UV2 unwrap?

As of Godot 4.2, lightmap rendering isn’t supported when using the Compatibility rendering method. It’ll be coming in Godot 4.3: OpenGL: Implement rendering of lightmaps by dsnopek · Pull Request #85120 · godotengine/godot · GitHub

Before unwrap 2:

I’m a new user so I can’t attach 2 screenshots in one reply.

After unwrap 2:

Quality isn’t my priority at the moment, so I hope you don’t mind.

strangely enough, baking without shadows on (in the Omni light) still bakes with shadows, but I had to turn off the environment in the LightmapGI.

I think this may actually be intended, given you have a LightmapGI instance in the scene. Lights (and their shadows) on static surfaces won’t be visible until lights are baked for lights that have the Static bake mode. This doesn’t apply to lights that use the Dynamic bake mode, whose direct light and shadow are drawn in real-time even on lightmappe surfaces (only their indirect light is baked).

What I find strange though is that you still get the real-time light showing up, but not its shadow. Usually, you’d have both (for lights with the Dynamic bake mode) or neither (for lights with the Static bake mode).

Can you open an issue on GitHub with a minimal reproduction project attached?

This is a known issue: Vulkan: LightmapGI always bakes direct light shadows (for fully baked lights), even for lights that have shadows disabled · Issue #56611 · godotengine/godot · GitHub

1 Like

maybe they are not disabled and all moved to same point, i dont know if im facing the same problem, there are images before and after unwrap

Can you upload the source mesh somewhere so someone can try to reproduce this issue?