Why do GPUParticles2D collisions (rigid/hide) need an LightOccluder to work?

Godot Version

Godot Engine v4.2.2

Question

I started using GPUParticles2D, and I found that when particle collision (on ParticleProcessMaterial) is set to Rigid/Hide on contact, particles stop spawning unless there is a LightOccluder2D in the scene. I don’t know why this happens, and I would like to know if there’s a way to make particles spawn with these settings without a LightOccluder. Ty.