100% GPU usage on debug

Godot Version

Godot v4.0.3
GPU Intel UHD Graphics 630

Question

When I try to run my relatively small game on debug, the GPU usage skyrockets to 100%.

I tried changing the fps from 0 to 30 in project settings, but it had no effect.
Is there a fix to this or is my graphics card just bad?

Thank you in advance!

what are you trying to run? also always check if you are instantiating+adding child of nodes a lot or not. usually that one makes the game run laggy. try uses Debug Menu - Display in-game FPS/performance/hardware metrics - Godot Asset Library, enable the plugin and press f3 during run debug to check the real fps of the game you try to run, if it’s laggy, the fps should below 30 for sure

1 Like

Hey!
Thanks for the reply
I simply “run current scene” of the 2d game I’m making.
Also how many child nodes is too much? (cuz I have only 12 nodes in total)
Also also I set my max FPS to 30 (in project settings) and it still lagged/used up all my GPU.

try fresh project without setting any fps limit or anything, and run with exact same node2d. if it’s lagged, then your pc has problem using the godot editor. because 12 nodes isn’t much, in fact it’s small. but still if you have a lot of Sprite2D with Big textures like 2k+ px size, it will lag even with just 12 of it

2 Likes

Thanks!
You were correct, my sprites are way too big… To check this I simply made some nodes invisible and tried running the scene again, and it was much better.
Gonna have to rework that.
Thanks once more for the help!

1 Like