Godot Version
4.3
Question
Following error:
I can’t fix it. If i delete “class_name player”, it starts once again. Tried deleting .godot folder, didn’t work.
Is there any solution to this??
4.3
Following error:
I can’t fix it. If i delete “class_name player”, it starts once again. Tried deleting .godot folder, didn’t work.
Is there any solution to this??
You must have another script with class_name Player
you could try to find this by searching all scripts with ctrl+shift+f
the problem is - i dont have one
everything happened after i changed name of one folder
Try writing Player
in your script and ctrl+clicking it or right clicking it and going to the definition.
Your class name conflicts with your function name.
Try deleting the function Player.
Guys, it’s not because there’s a different class this name. All this happened after I renamed 1 folder’s name. Everything was working fine. If I delete player class it does the same with every other class
Check if the node that refering to this script has a right reference.
My “Player” node refers to “xxyy/xxyy/player.gd”, but the script is actually “Player.gd”.
Everything goes well when I renamed the script file to “player.gd”.
Any update on this? Could you please share if you were able to find a solution?
Got exact same issue on my end as well
I had the same issue, with a different version by the past.
If I remember correctly, it’s a problem on windows, with the naming system, on windows it’s not case sensitive, so I had to recreate the project with the correct name I want for the scripts, and past the code in the new file.
Renaming by upperCase or lowerCase is not possible on windows system (donno for 11, I mean for previous version), but godot let you do it, but he can’t save the file correctly, I’m not sure about this last, but godot is Case sensitive so he doesn’t see the problem.
If your problem fits with my comment and you really need to rename your file with only upper or lower case modifications, try update like this: player.gd → Player2.gd → Player.gd (every “->” means that you save the file). But it’s probably a better way to follow the Godot official naming convention.
Do you think you could please elaborate on this? What’re you saying the issue might be? I think I might be having a similar problem but I can’t quite tell. I’d greatly appreciate it!