Dotnet Godot 4 games require glibc versions beyond what my still supported linux handles

I downloaded this game, Rixas by elfkan
computer tells me it needs glibc versions of at least 2.32
I am running Linux Mint 20.3 Cinnamon, my current glibc version is 31, missing the backwards compatibility by a single version.

in this post:

Akien says
"Not supporting Ubuntu 18.04 is not a bug, it’s a decision.

Linux binaries can only support at most versions of glibc newer than the one they were compiled against. Godot 4.2 is using newer toolchains (GCC 13) and glibc (2.28), which is not supported by Ubuntu 18.04.

Ubuntu 18.04 is EOL since May 2023, so we don’t aim to support it."

How about supporting 20.04, which will be supported until 2025?

I think you got three options, ask the game dev to export the game for 20.04, go on Godot GitHub and make an issue, or upgrade your Linux distro.

A fourth option would be to compile the engine yourself, but that probably wouldn’t solve the problem… Probably complaining to Godot wouldn’t fix it either. Your best bet is talking to the devs or upgrading.

Godot does support ubuntu20.04 and glibc 2.31, at least the downloads provided on the Godot website.

The developer of this project has probably compiled godot from source themselves on a much newer system, or perhaps they are an arch user who has installed it from the system pacakges.

You’ll need them to either re-export it using an official version or you could hack it, download godot yourself, plonk the binary next to the pck, cross your fingers and run it.