Draw_arc refuses to animate

Godot Version



I’ve been trying to draw a circle with draw_arc, and animate it with an AnimationPlayer. It doesn’t seem to draw.
Here are the relevant parts of the Node2D that parents the AnimationPlayer. Looks simple enough.

func _process(_delta):

func _draw():
draw_arc( Vector2.ZERO, radius, (0.0), (2 * PI), points, color, width, antialiased)

Those are all export variables, and the AnimationPlayer has three keyframes that control the radius. There’s a function that successfully triggers the animation, but the animation isn’t visible.
This is my first time with _draw so I might be missing something basic? I successfully drew a static arc, and ensured there’s nothing covering it and so on.

Hello, I recreated your setup with Node2D and AnimationPlayer and it works without issue. So when you play the animation, do you see a static arc, or do you see nothing at all?

1 Like

Thank you for testing @shatteredreality!
Knowing it worked for you, I went back and pounded at it again. It displayed a static arc in its default state, then disappeared when the animation triggered.
Stupid oversight, though. A keyframe had reverted to a small value and I didn’t catch it < facepalm > It works now :smiley: