[Godot 4.1.1] Release build has crashes that the Debug version doesn't have

Godot Version

4.1.1

Question

Hi! I finished a really REALLY small demo of my game. It still has some bugs but the most annoying one is that the release version crashes when the game ends and you want to either quit or go to the main menu. Then it just closes.

This, however, does NOT happen in either a Debug version or in the Godot editor.It ONLY happens in the release version which is for Windows 10 32 and 64 bits. I used both the PCK file build and the embedded PCK build. Both show the same result.

I still don’t know how to paste code correctly here but I would like to show you the code I use to change the scenes.

CODE:

extends Control

@onready var main_menu_ref: PackedScene = load(“res://MainMenu/MainMenu.tscn”)

func _on_main_menu_pressed():
get_tree().set_pause(false)
get_tree().change_scene_to_packed(main_menu_ref)

func _on_quit_pressed():
get_tree().quit()

I don’t know where else to look or what to do, could it be that I need some sort of manager or something?

Can you try 4.1.4? 4.1.1 is an older version that’s no longer supported

Oh, I didn’t think about it. I’ll try that and see if it works, thanks for the info, I’ll post something when I try it!

Yep, it was just that. I tried with the 4.2.2 version and it works just fine. No more crashes!

I tried changing the location of the game, repeating the previous error scenario but it no longer crashes.

I’ll keep fixing the other bugs. This one has been killing me for weeks already.

Thank you very much!

1 Like