Godot won't launch or open (but it's running in task manager) FIX!

Hey guys, I just wanted to share a solution to why Godot won’t open even if you see it running in the task manager. I was having this issue for the longest time and really could not figure out why. I even tried going into safe mode and it still would not open. I tried everything, even turning off my Windows Defender and firewall. It still wouldn’t even launch.
It turns out it was my MSI audio driver. Nahemic 2+ software. As soon, as I quit that application. Godot will launch. If I open up Nahemic, Godot will no longer launch. So I uninstalled that crapware (which I found out is not required). I also found that Nahemic was blocking a lot of itch.io games from launching properly too.

I thought I just share this info for anybody who has a PC or Laptop that uses Nahemic audio drivers such as MSI motherboards or MSI laptops. Uninstall it and you should be able to open Godot with no issues.

1 Like

Yeah, seems to be good advice in general to disable Nahimic (it comes on Dell/Alienware too). Haven’t run into that particular bug – for me it was running in-editor not working on a secondary monitor in Godot – but it seems to cause a variety of hard-to-troubleshoot problems with windowed applications.