How to disable snap to pixel for one node?

I’m making a low-res pixel art game. When I have Snap 2D Transforms to Pixel enabled Particles jitter if the GPUParticles2D is moved. Disabling the option fixes this but this applies to everything else too.

Is there a way for nodes to opt out or another way to avoid the jitter?