LineEdit don't allow to enter fractional numbers when exporting to Android

I ran into a problem. lineEdit does not allow the user to enter fractional numbers. It does not allow you to enter anything other than integers (even insert a copied number). In this case, virtual_keyboard_type = decimal(3). If you set “default”, you can put a dot, but this is inconvenient because you need to enter 7 numbers. However, this problem appears only when exporting to android. When launching an application from GodotEngine on a computer, you can enter anything in this field.

which type you set to? number or number decimal?

I use “number decimal” (I’ve tried all the others too). I also tried to set this parameter through the code.

so it cant enter “.” but have you tried entering the “,”?
because decimal separator for different countries are different
it could be a dot or a comma

I tried to enter both a dot and a comma, but they just don’t enter. Only integers are entered. Both “number decimal” and “number” have the same virtual keyboard and work the same way.

If I set “default”, then I can enter anything, including a fractional number. The fact is that it is inconvenient to switch the keyboard on a smartphone many times.

Android release does not allow for decimal values on number or decimal type virt keyboard when using line edit with RegEx · Issue #84091 · godotengine/godot · GitHub actually there’s a bug right now, and will be fixed on 4.3

the fix:

1 Like

I suspected this, the project was originally on 4.1 and had this problem. I upgraded to 4.2 and nothing has changed, so I thought the problem was something else. I will hope that they will fix it soon.
Thanks for the help!

Indeed, this is already on the list of changes

is that in 4.3 changelog?
wel no, it’s implemented in 4.2.2 and 4.1.4

I found it here Godot Interactive Changelog

what version you are using right now? because i read in changelog 4.2.2, there’s the bug fix for it
Godot Interactive Changelog. and Godot Interactive Changelog.

However, I have already checked this on Godot 4.3 dev 6, but nothing has been fixed there yet.

4.2.2 and 4.1.4 fixed it, upgrade to either of it

It still won’t let me enter the fractional number.

have you redownloaded the export template?

Yes, the template has been established.

ok… then idk what’s wrong again, the upgrade should have fixed it, but it seems your device doesnt
which android device you are using?

Xiaomi Redmi note 9 (Android Version 11RP1A.200720.011). I also checked it on other phones.

I created a completely empty project on version 4.2.2 and put a single lineEdit in it. He still won’t let you enter a fractional number