Marker2D rotation property does't work

Godot Version

4.2.1 stable

Question

I want to rotate the Marker that the player’s hitbox attached to, but it don’t rotating. Slider is frozen, attemts to enter the value ends with initial 0. In 2D scene, the attached hitbox node indicator moves for a milisecond and then retunts to 0 degree position.

In the tutorial all works, but there is Godot 3.2 version and there is Marker2D is Position2D. Today I updated from 4.1.3 to 4.2.1, whereas my test project was originally created on 4.1.3.

Can’t show it with .gif or .mp4, because OBS isn’t installed for now.

Shapes with sprite:
image

Shapes without sprite:
image

Hitbox structure:
image

Marker’s inspector:
image

Collision Shape’s inspector:

The rest is unchanged.

Just made a scene to try this and works fine on my end (4.2.0). Stupid question, but you sure you have the marker selected in the scene tree when changing rotation?

If you can upload a proj with just this scene (or whole thing), happy to take a look.

Yes, I’m trying to change rotation Node2D in Marker2D inspector.

I’m not having any problems rotating in my test project. Sec, looking at yours…

This is an absolute mystery. I get the same behavior in your project. However, if I copy that marker2D and paste it back under same parent (Player), the pasted Marker2D can be rotated no problem, but the original one cannot be.

If I create a new Marker2D + Area2D + CollisionShape under Player, this new one can also be rotated no problem.

I checked the .tscn file in text editor and couldn’t find any issues. Freakier still, if I add rotation to the original Marker2D in the .tscn file itself on hard disk and reload the scene in godot, the rotation disappears! And if I then save the project and check the .tscn file on disk again, rotation is no longer in the file.

This makes no sense.

I don’t know what to tell you other than you got yourself a possessed Marker2D. Thankfully the demon doesn’t jump to new bodies so just copy-paste that Marker 2D and delete the original and you’re good to go.

1 Like

I also just tried out the test project and it doesn’t rotate while other markers rotate. Even a duplicate of it works. It looks like a bug with that particular instance if the Marker2D.

2 Likes

Hello, well, I’m here again. That happens when I key on timeline any parameter in AnimationPlayer (maybe not any, but which is related to positioning):

If I just key parameters and then edit their values in KeyEdit, it’s works. But in situations when I need to to see what I’m changing, it’s not very convenient. What are your thoughts then?

p.s. of course, I can just remember values and then enter them into each key, but I want to figure out why it’s happening.

Ahh, sorry, I have no idea how this locks up rotation or why - I haven’t worked with AnimationPlayer yet.

1 Like

irmão eu descobri que era a AnimationTree ativada.
desative e tente de novo, pode ser que de certo.

Well, seems to work, thank you!