Mouse cursor hiding itself in editor when hovered over text fields

Godot Version



I remember this happening a while ago and stopping, but now it’s started again and I can’t figure out how to fix it.

Basically, my mouse cursor works as normal most of the time, but if I am working in the Godot editor and hover it over any typing field like a search bar in the editor or, most notably, the script terminal, it just disappears. This makes it extremely difficult to code. It randomly started last week while I was working, I have no idea what caused it. There appears to be no mouse or cursor Editor Settings so there doesn’t seem to be a way to easily fix it. I do not have the Windows setting turned on to hide the cursor when typing (I’ve never used that, I hate it), but even if I did, this would not be the exact issue I’m having as it hides the very second it passes into the text field, not the second I type. This only happens in Godot and does not occur in any other program.

I have closed and opened Godot many times since this started, as well as restarted and updated my computer multiple times. I’m running Windows 11 23H2.

I have posted this to the Godot Engine Github Bug Reports.
At this link, another user found that the solution is to disable HDR in the Windows settings. Very bizarre, I hope a fix comes out.

Search for Caret Color in editor settings. What’s it look like?

ffffff and 000000 for the color codes