Problem with bleeding Textures

Godot Version



Hello ya all,

i have a problem with my textures/meshes. I use a plugin called “LevelBlock” to build a level for my old school dungeon crawler. But the textures are bleeding as you can see in the picture i have uploaded. I tried AA and Scaling 3D Mode FSR 2.2 which kind of solve the problem but give me other problems. AA will make my AnimatedSprites3D look weird and FSR 2.2 seems to have a big impact on my performance.

Bleeding example

Using FSR 2.2

Using AA - Take a close look at the bat and at the top of the fire. It looks kind of blurry.

I’m not sure what you’re referring to as “bleeding”, but it looks like you have some extra geometry instead of flat textures??? I don’t know what is happening in these pictures.

@Efi , thank you for dealing with my problem. I’m not sure “bleeding” is the right term.
For better context:
This is a 3D game with 2D sprites. I also use an addon that provides a new node, the “LevelBlock”. This node creates a box mesh and adds textures. My problem is that sometimes there is a fine line between the textures when I place the blocks next to each other. If you look closely at the first image, you can see it. There are two small black lines separating the “blocks”.

Ok, that’s not bleeding or a texture issue, that’s a geometry issue. That means there’s imprecission in the way the geometry is calculated. Try setting your camera to have a closer far plane and further out near plane and see if that fixes this, specifically. The default for a godot camera allows you to see very far in the distance, but since you are using interiors and a relatively close perspective, you are losing precision to the far plane, mostly, for no gain.

1 Like

@Efi , I played around with the camera “Far” and “Near” settings in the inspector but it does not seem to work.

But: Changing the V Offset to 0.001 fixed the problem. :smiley:

that… is a very strange behaviour that shouldn’t be a thing??? but if it works…

Yes, it is strange, but at least I don’t see any problem by using this approach. Thanks again for pointing out the solution!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.