Progress bar visuals

Godot Version

Godot 4.2.1.stable

Question

I followed a tutorial on how to make a working progress bar, and it said to put the bar as a child of the canvas layer node to make it follow the screen but that didn’t work and it would just stay in place. How do I make it follow the screen? (I’m also using the TextureProgressBar node)

1 Like

Hey,
It might be that you are encountering a bug for the UI.
BASICALLY: The first child node is glitched, in this case the progress bar. Just make a label the first child node (so it takes the glitch hit) and then it should work.
Have had this problem myself before

I’m really new to Godot, is making a label for it just renaming it, and what is a glitch hit? (Also thank you for the help).

It means you found a bug. The way you did actually is the correct way, so if its not working, maybe is because a bug you found.

This is a known bug, assuming you’re on an intel integrated graphics

He is telling you to add a Label as the first child of CanvasLayer.
The first child of the CanvasLayer will not position correctly so in this case it will be the dummy label you just added. (ie the label “takes the hit”)

2 Likes

True, that should solve the issue

Thank you.

Unless I’m somehow messing something this simple up, the progress bar still stays in place, even if I make it the 3rd child of the canvas layer. (And I know this is the wrong place for this but a mini question, why does my pc say I have a 1050 TI, the same for Godot, yet user benchmark says I have some coffee lake thing and the forum says a 1050 TI should work)

Do you have a laptop with hybrid graphics (NVIDIA Optimus)? If so, this is because the web browser is running on integrated graphics but Godot is running on your dedicated GPU (the Vulkan driver will favor dedicated GPUs when available).

1 Like

Could you send a screenshot of your UI scene?
It should look like this:
CanvasLayer
-Label #takes the bug
-VBoxContainer
–ProgressBar

No I have a full desktop

Ahhhhhh. That might be the problem, I don’t have the VBoxContainer.

Edit- Nope still doesn’t work. Is my GPU/CPU just not powerful enough maybe?

Edit- I just messed around and it doesn’t look like anything is different from when I first tried this but it works now for some reason

Thats great to hear
Have a great day

You too.

1 Like