Rendering Problem with Lights (Compatibility Error)

Godot Version

4.2

Question

Good morning : ) , someone please tell me you know how to solve these rendering problems? There are some lights and you end up having these 2 problems, the first one with this black tab and the second one about these cut off lights. If I’m being vague about this, please let me know and I’ll give you as much information as I can : )

I use compatibility (GLTF3) mode.

I would check the vert normals on your geometry, they look like they either corrupt or just not setup right. Where are you getting this geometry?

Also show more about that scene setup like where are the lights in that scene, maybe show the Normal Buffer display mode (under advanced if you click on the three dots on the top left of the viewport, next to where it might say Perspective), maybe show under lighting mode too.

I just looked here, and I realized that the black tabs problem was because there were 2 meshinstances in the same location. But I still don’t know how to solve the problem of cut off lights. This track is actually not just one, it’s several small tracks that make up a single track. It seems that the error is there, she is acting as if she renders herself a new light with each ‘piste’

I just looked here, and I realized that the black tabs problem was because there were 2 meshinstances in the same location. But I still don’t know how to solve the problem of cut off lights. This track is actually not just one, it’s several small tracks that make up a single track. It seems that the error is there, she is acting as if she renders herself a new light with each ‘piste’
And the vertices, I don’t know where it looks here on the godot, and the shader mode is per pixel

One thing to do is hide every light except the Directional one, so we can see the lighting from the same source.

If you can also, toggle off the wireframe view on the meshes, not sure how you are showing that one.

Show that same view with the above setup, and have nothing selected when that is done.

The two modes that might be helpful are:

Maybe show what you see with those modes.

Where are you getting the meshes from, is it a blender file?

Here. I put the options you asked for, but I think I’m dumb enough because I didn’t see any difference or I didn’t understand any part. Also, meshes are .obj, I didn’t make them, I got them on the internet.

Also, I disabled all the lights except the directionalLight3D and this error is gone. So the error is in SpotLight3D. Another thing, the flaws of these squares are precisely in the other pieces of clues. That is, it seems that the light is only rendering on the piece of track next to it, not making a linear effect which is what it should be. All the blocks are the same, so they’re not on a Different Light layer. I think the mistake is in this: The Light does not illuminate in a linear way, but takes the whole mesh.

And ah! the SpotLights are right on the pole, where they sit in real life, at the ends

Can you show the Normal Buffer viewmode I listed above?

Also where on the internet were these .obj’s available at?

Forgive any mistakes, I’ve never used this type of mode before but doing what you said, as I’ve already said, didn’t change anything. Here’s a picture of that, and the models are from the Kenney.nl

This mode may not work in GLTF3 (compatibility)

1 Like

Ah yeah, the Normal Buffer mode doesn’t work in the compatibility mode, my bad.

The obj meshes look fine and light well in a quick test setup in compatibility mode on my end. What version of Godot are you using?

Things to check also:

  • Look for any odd transforms on the meshes, all the nodes associated to them, mainly any negative scaling.
  • Check that for the Spotlight3D also, make sure they are pointing down and not scaled oddly. If they are parented to another node, check that too.
  • Until it’s figured out, remove any or all materials used on the MeshInstance3D that are not default that came with the kit, just in case.
1 Like

4.2
And I just looked at it and there are no negative transformations (there were only in 1 that wasn’t aligned on the XYZ axes, but I’ve already fixed it and it didn’t solve something). Also, I removed all non-standard materials (I had only used 1 material). In general, I looked at everything you said and nothing. My guess is some bug in godot’s native rendering model in compatibility+ that causes light to not linearly affect all meshes. I’ll have my new computer next month, I’ll see if this bug occurs in forward+, I think it’s my only chance =/

Or maybe some way to unify or get godot to treat these nodes as one (something like blender’s CTRL+J) would do the trick