Sprite blurry/is ghosting while running in Godot 4

Godot Version

Godot 4.2 (Windows 64-bit)


I’ve recently started a project in Godot 4, but it seems the character has some sort of blur/ghosting when i make it run horizontally that i dont know how to get rid of
How do i get rid of this?
(This isn’t a monitor issue, as in Godot 3, at the same speed and everything this doesnt happen.)

In Project Settings go to Rendering, Textures and double check your Default Texture Filter is set to Nearest.


It is set to Nearest, so I don’t know what’s wrong with it

Well, show more about your project. If it’s not the obvious thing, maybe you have something in your viewport or textures that is not how it should be.

It’s pixel art (made in aseprite and exported into .PNG) with the screen resolution at 320x180 but maximized, etc

Here’s a gif showing it: IMG-3378 hosted at ImgBB — ImgBB
It’s faint, but visible and this does not happen in my Godot 3 projects

Sure, but what are the import settings etc?