Turning off V-Sync doesn't stop "V-Sync is not supported" warning

Godot Version

4.2.2.stable.official [15073afe3]

Question

I am using the Godot Engine on a VM, so I’m using RDP to access it. Every so often I get this warning in the editor:

“platform/linuxbsd/x11/gl-mananger_x11.cpp:374 - Could not set V-Sync mode. V-Sync is not supported”

Which is true. So I set Display > Window > V-Sync Mode to Disabled but the warning persists.

It’s minor, but starting to get annoying. At least I found the “collapse duplicate” button!

Is this a bug, or is there another way to turn off V-Sync, or turn off this warning?

Sounds like a bug to me. The warning is stemming from here, where it will be issued no matter what value p_use is provided. You might want to open up an issue on GitHub.

Does it behave differently if you provide the --disable-vsync flag when launching Godot from a terminal?

I’m sorry, feeling dumb here…
If I open a terminal:

$ cd /home/tobyjones/Desktop/Godot_v4.2.2-stable_mono_linux_x86_64/
$ Godot_v4.2.2-stable_mono_linux_x86_64 --disable-vsync

I get ‘command not found’ (though that’s what I click to start Godot)

This is because the current working directory is not part of PATH on Linux for security reasons (this is also the case on Windows when using PowerShell instead of cmd). You need to specify the relative path to the Godot binary instead, that is:

./Godot_v4.2.2-stable_mono_linux_x86_64 --disable-vsync

Thanks! It still tries to set V-Sync, and I get the same warning in the editor.

tobyjones@GodotServer:~/Desktop/Godot_v4.2.2-stable_mono_linux_x86_64$ ./Godot_v4.2.2-stable_mono_linux.x86_64 --disable-vsync
Godot Engine v4.2.2.stable.mono.official.15073afe3 - https://godotengine.org
WARNING: Could not set V-Sync mode. V-Sync is not supported.
at: set_use_vsync (platform/linuxbsd/x11/gl_manager_x11.cpp:374)
OpenGL API 4.5 (Core Profile) Mesa 23.2.1-1ubuntu3.1~22.04.2 - Compatibility - Using Device: Mesa - llvmpipe (LLVM 15.0.7, 256 bits)

  • platform/linuxbsd/x11/gl_manager_x11.cpp:374 - Could not set V-Sync mode. V-Sync is not supported.

I’ve reported the issue, thanks for your help.