Weird error that I dont know how to fix

v4.2.1

Hello, I am pretty new to the engine and game development in general. And Ive been following a youtube tutorial to learn the basics. But out of nowhere some error messages popped up in the output tab.

For example:

platform/windows/display_server_windows.cpp:2569 - Parameter “hicon” is null.
Failed to create Windows OS window.
Failed to create sub window.
scene/main/window.cpp:592 - Condition “window_id == DisplayServer::INVALID_WINDOW_ID” is true.

Everything in the engine still works the same, when I run the game everything also works correctly but these errors just appear every few minutes and idk why.

Also sorry I know this isnt really a UI oriented question but I didnt know where else to ask.

Can you show the code or script where this error happens?
We cannot help you without having a look at it.

Remember to use this option when pasting code so it gets formated
image

So it can look like this

var like_this := 1

func and_something_like_this:
     pass

Thats the wierd part… As far as I can tell… I happens on every scene.

NEVERMIND… It was an issue with my computer not with the engine, I fixed it. lol

1 Like

@Kalamar how did you fix this issue? iv been having this problem using any godot version after 4.1.3

This happens to me every time opening godot & creating any new scenes, also while running i get these errors not sure about the “corrupt pipeline cache” thats new since using the 4.3 dev build

snip02

hey im getting this issue too, i know you said its something with your computer but im not sure what it was, could you tell me how you fixed it?

1 Like

I am also having the same error message. To be honest, I don’t even know what it means, everything seems to work fine.

Not sure if this is relevant, but some digging tells me this “hicon” is something to do with the .ico file for windows, my assumption is either:

  1. The godot.exe .ico file is somehow corrupt
  2. Your project’s icon file is somehow corrupt/missing

If any of you have deleted the godot.png from your project, and not replaced it with anything else for your project icon, I would assume this would cause the error, I haven’t tested yet however.

1 Like

Yeh it has something to do with the icon (i made another topic post here
iv tryed many different versions of godot and also most recent an all have this error.
This also happens without even deleting the dafault icon, im running runing windows7 on this PC maybe that could be the problem? as im thinking it could be more down to something like that and as the OP mentioned it was down to his pc but never revealed there fix i cant be sure.

I’m also running Windows 7 and have this error, and I definitely thinks that the reason, like, the icon system for Windows 7 is not supported by Godot anymore probably, not like it’s a biggie, but I guess that another reason we have to move over to a more recent OS lol

1 Like

I’m on Windows 10 and I have the same error :confused: