Help needed - Transparent pixels in assets not recognised when placed in scene?

Godot Version

Godot Version 4.2.2

Question

Hello everyone!

I am a first time godot user, and a total newbie to programming and gamedev so I’m completely out of my depth here - any and all help is welcome!

I’ve created a tile-set (all the tiles are 11px by 11px) for my scene. Lots of the assets have transparent backgrounds but they all use transparent pixels to fit within multiples of 11x11.

For some assets, I’ve centred them specifically within their transparent tiles in order for them to look a certain way when layered.

I’ll try to explain in as much detail as I can (sorry if I’m over-explaining).

Here’s an example:

These are two of the assets: chest of drawers and a lamp. The drawers are 33 x 33 and lamp is 22 x 22 but everything outside of the outline is all transparent pixels.

I constructed them within their tiles this way so when I layer the lamp on top of the drawers it looks a specific way:

So I hope it makes sense when I say the transparent pixels are necessary - sorry if y’all already know this and I’m just rambling.

Going on from this, when I set up the tilemap in godot the tiles seem to reflect all of these transparent pixels:

But when I try to add the tiles into the scene, something goes wrong?

These were the closest places the tilemap feature allowed me to place the lamp and none of them were where I designed the asset to be. Also, none of the four sit within the 22x22 tile in the way I placed it, at least according to the orange grid on screen.

This is happening with most of the assets with transparent backgrounds and I’m not too sure what I did wrong or why this is happening.

If anyone knows what’s happening or what I can do to fix it that would absolutely amazing!

Thank you for reading!

the grids might just not align since the tiles are different sizes, unless the dresser sprites are split up into multiple 11x11 sprites rather than one big 33x33 sprite, in which case i dont know what could be happening
if the tilemaps are different sizes, i’d suggest changing them to all be 11x11 (so for the drawer it would be made of multiple 11x11 sprites rather than one big 33x33 sprite) to ensure that they line up properly in the grid. alternatively, you could just set the tile size in both tilemaps to 11x11 which i think should also make them line up

1 Like

You are an absolute legend - thank you so much!

You were right, I had created the dresser as one big 33x33 tiles instead of multiple 11x11 tiles so I changed it all to be multiple 11x11 and it worked like a charm!

I tried it with a few other assets as well and it’s all working now! Thank you heaps! :smiley:

1 Like