How to make godot 4 code editor have better scaling when used on a second high ppi monitor

Godot Version



So I got 2 monitors, My main which is 1440p 27inches and my second, secondary 4k 28inches.

I would like to use my secondary as my coding monitor although, when using the built in IDE and displaying it on my second monitor it looks really bad.

The reason being since windows doesn’t scale things well all it’s doing is stretching the text giving it that ugly look as shown in the picture (Here’s another picture from my primary monitor if that helps

I’ve seen in editor setting that you can change scaling and that but doing that then scales my main monitor where everything else is and makes that look bad and it seems you can only change the font size for the editor which doesn’t help sadly

Does anyone know a fix for this? I’ve thought about using vscode but then I’m loosing the drag and drop feature of node referencing which defeats the whole propose on what im trying to do.

I’m also on windows 11 if that helps.
Thank you!