Problems giving height to a 3D mesh with a shader

Godot Version



I have a 3D mesh that lifts its vertices with a shader, the Y vertices are lifted based on a Texture.

The problem is that when the white color is on the edge of the texture, the vertices are reflected on the other side of the mesh.

How can I avoid this problem?

Try setting the sampler to not repeat:

uniform sampler2D vertex_up : repeat_disable;

You can find more information in the docs for uniforms.

1 Like

Thank you very much ^^

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.